InfiniteMac OSx86  


Reply
 
Thread tools Display modes
  #1  
Old 07-03-2009, 12:42 AM
andyvand's Avatar
andyvand andyvand is offline
 
Join Date: Apr 2009
Location: Tienen
Posts: 515
AnV XNU 9.7.0 V1.5

I recently had a lot to do with my life so... no time....
But now I've found the time for the new and improved AnV kernel with extra good memory management and Core i7 optimizations.
Enjoy...
Download for the new version (including source):
http://rapidshare.com/files/26536154...-970-1.5.1.zip
Legacy AppleIntelClock driver download:
http://rapidshare.com/files/25123900...IntelClock.zip

It could be a little while longer when you'll hear from me (unfortunetely).
You'll hear from me in a little while (I'm not done/gone yet...)

Last edited by andyvand; 08-09-2009 at 09:34 AM. Reason: New version
Reply With Quote
  #2  
Old 07-03-2009, 12:55 AM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
Thanks, I'm going to try it and let you know how it works.
Reply With Quote
  #3  
Old 07-03-2009, 12:57 AM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
Do I need to install IPFirewall.kext ?

What it's used for?
Reply With Quote
  #4  
Old 07-03-2009, 01:03 AM
andyvand's Avatar
andyvand andyvand is offline
 
Join Date: Apr 2009
Location: Tienen
Posts: 515
IPFirewall.kext is the firewall pseudoextension...
It is used for controlling the firewall in the kernel
Reply With Quote
  #5  
Old 07-03-2009, 01:27 AM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
No luck.

Renamed kernel file to mach_kernel, copied it to system partition root w/replace. Installed System.kext, seatbelt.kext, and IPFirewall.kext using OSXTools. When I reboot and select my Leo partition in Chameleon boot menu it goes to Apple logo screen where it just loads forever.

Reverted to 1.4, all works fine again.

-AMD Opteron 180
-Leopard 10.5.6 retail installed
-10.5.7 Update applied
-Chameleon 2 RC1 used to boot
Reply With Quote
  #6  
Old 07-03-2009, 04:55 PM
eMatoS's Avatar
eMatoS eMatoS is offline
 
Join Date: Jan 2008
Location: Argentina
Posts: 185
Working great so far in my pc (signature)
I've installed only the kernel and used original system, seatbelt and ipfirewall kexts.
Andy, what's the difference between vanilla and your system.kext??

Thank you very much andy for taking the time to do this.

CPU: AMD Athlon 64 3000+ @2.3Ghz - Motherboard: ASUS A8N-SLI nForce4 SLI - nForceLAN by eno - SuperNForceATA by Medevil - RAM:2 GB DDR 333Mhz Audio: ALC850 Video: XFX nVidia GeForce 8400GS 256Mb (0x06e4) QE & CI from Chameleon 2 RC4Ethernet: Realtek RTL 8139 Series (working out of the box) OS: Snow Leopard 10.6.4 (aryajuanda's guide) + Windows XP 64bits
Reply With Quote
  #7  
Old 07-03-2009, 06:16 PM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
I don't know why it wont accept new kernel on my system. :-(

I used AnV 1.4 to install and run retail Leopard 10.5.6.

Can it be some conflict with the Chameleon 2 RC1?
Reply With Quote
  #8  
Old 07-03-2009, 10:15 PM
SaCleoCheater's Avatar
SaCleoCheater SaCleoCheater is offline
 
Join Date: Apr 2009
Location: England, South-East
Posts: 187
Great to hear from you Andy!

Kernel works like a charm on my P4

@Andyvand: Mother finally gave in LOL! - OS X FTW!

My Specs
System: Custom Built
Mobo: ASRock Z68 Extreme4 Gen3
OS:Mac OS X MountainLion 10.8.2 & Windows 7 Ultimate x64
CPU: Intel Core i7 2600k @ 4.2GHz
Memory: 16GB DDR3 XMS3 1600MHz
Graphics Card: AMD Radeon HD 6870 1GB

Email/Gtalk:
sacleocheater92@gmail.com
Reply With Quote
  #9  
Old 07-03-2009, 11:10 PM
diskeeper's Avatar
diskeeper diskeeper is offline
Jaguar
 
Join Date: Jun 2008
Location: Hungary
Posts: 64
Same here maya77. Boot stopped on "using 16384 buffer headers and 4096 cluster IO buffer headers". The next line should be ACPI?

Mac OS X 10.7.2 11C40 - Vanilla kernel
Gigabyte GA-P43T-ES3G - Intel Q8300 - 4 GB Geil DDRIII 1333MHz
EVGA GeForce GTX 460 SC 1024 MB - Linksys WMP54GS PCI
Reply With Quote
  #10  
Old 07-04-2009, 12:03 AM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
So AMD + retail Leopard (boot-132 method) + updated kernel = no boot

There must be something which needs to be updated before installing new kernel. But what it can be?

Andy?



💡 Deploy cloud instances seamlessly on DigitalOcean. Free credits ($100) for InfMac readers.

Reply With Quote
Reply
Thread Tools
Display Modes